□ 개요

 o HP社의 잉크 프린터에서 발생하는 원격코드실행 취약점을 해결한 보안 업데이트 발표[1]

 o 취약한 버전을 사용 중인 서버의 담당자는 해결방안에 따라 최신 버전으로 업데이트 권고

 

□ 설명

 o 입력값에 대한 검증이 미흡하여 원격에서 조작된 파일을 해당 장비로 전송하는 경우, 스택 또는 스태틱 버퍼오버플로우로 발생하는 원격코드 실행 취약점(CVE-2018-5924, 5925) [2][3]

 

□ 영향을 받는 제품

 o 보안공고 페이지[1]의 Resolution 부분에서 제품이름과 제품번호를 참조하여 확인

  - PageWide Pro 제품군

  - HP DesignJet 제품군

  - HP Officejet, HP Deskjet and HP Envy 제품군


□ 해결 방안

 o 보안공고 페이지[1]에서 Resolution 부분의 Firmware Revision을 참고하여 최신버전 확인 후 제품 검색[4] 후 업데이트 진행

 o 외부에서 인터넷을 통해 복합기를 사용하지 않는 경우, 방화벽 등을 통해 53048포트 접근 차단


블로그 이미지

Ryansecurity Ryansecurity

Life is fun security story

티스토리 툴바