아래한글 임의코드 실행 취약점 보안 업데이트 권고2014.03.17

개요

  • 한글과컴퓨터社의 아래한글 등 오피스 프로그램에서 임의 코드실행이 가능한 취약점이 발견됨 [1]
    • 공격자는 특수하게 조작한 웹페이지 방문 유도 또는 웹 게시물, 메일, 메신저의 링크 등을 통해 특수하게 조작된 문서를 열어보도록 유도하여 임의코드를 실행시킬 수 있음
  • 영향 받는 버전의 사용자는 악성코드 감염에 취약할 수 있으므로 해결방안에 따라 보안 업데이트를 권고함

해당 시스템

제품

영향 받는 버전

(보안#17)

영향 받지 않는 버전

(보안#18)

/글 2014

9.0.0.993

9.0.0.1086

/셀 2014

9.0.0.989

9.0.0.1081

/쇼 2014

9.0.0.1016

9.0.0.1108

/글 2010

8.5.8.1401

8.5.8.1409

/셀 2010

8.5.8.1317

8.5.8.1321

/쇼 2010

8.5.8.1462

8.5.8.1466

/글 2007

7.5.12.686

7.5.12.692

넥셀 2007

7.5.12.747

7.5.12.751

슬라이드 2007

7.5.12.890

7.5.12.894

/글 2005

6.7.10.1102

6.7.10.1105

/글 2004

6.0.5.796

6.0.5.803

/글 2002

5.7.9.3073

5.7.9.3076

 해결 방안

  • 한글과컴퓨터 홈페이지에서 보안업데이트 파일을 직접 다운로드 받아 설치하여 영향 받지 않는 버전(보안#18)으로 업데이트
  • 한글과컴퓨터 자동 업데이트를 통해 최신버전으로 업데이트
    • 시작 → 모든 프로그램 → 한글과컴퓨터 → 한글과컴퓨터 자동 업데이트

ss

dd

 문의 사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

기타

  • 아래한글 임의코드 실행(XML 정수오버플로우) 취약점은 KrCERT 홈페이지를 통해 생계형해커@GoN 님께서 제공해주셨습니다.
  • 아래한글 임의코드 실행(WPG 힙오버플로우) 취약점은 KrCERT 홈페이지를 통해 이형섭(kill_5byte) 님께서 제공해주셨습니다.
  • 아래한글 임의코드 실행(PLT/HGL 힙오버플로우) 취약점은 KrCERT 홈페이지를 통해 현성원(sweetchip) 님께서 제공해주셨습니다.
  • 래한글 임의코드 실행(Hwpml 스택오버플로우) 취약점은 KrCERT 홈페이지를 통해 sweetchip(현성원)@BOB 님께서 제공해주셨습니다.

[참고사이트] 
[1] http://www.hancom.co.kr/downLoad.downPU.do?mcd=001

블로그 이미지

Ryansecurity Ryansecurity

Life is fun security story

티스토리 툴바